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Spreadsheet Handout 

 
Creating a Spreadsheet of Student Grades 

1. Open Up Microsoft Excel by clicking on the X icon on the dock.  
2. In the Project Gallery, click on Cancel or OK. 
3. In Cell C6 (which means Column C Row 6), enter Student Name.  
4. Then Enter the data like this:  

Student Name History CS110 Pre-Calc Total Score Final Score Grade 
Sam 90 87 80    
 
Downloading a sample spreadsheet 

1. First open up Safari by clicking on the safari icon on the dock.  
2. Then in the location box, type: http://www.eden.rutgers.edu/~kiritk/sample.xls 
3. The file is automatically downloaded onto the desktop.  
4. Double-click on the samplet.xls icon on the desktop to open it up in Excel.  

Saving Workbook 

1. Go to File->Save Workspace  
2. Choose Desktop in the Where box.  Then click on the arrow next to it.  
3. Choose Save. 

Formatting Text  

1. Select the cells containing the heading names (C6:I6)  
2. Click on Format->Cells.  
3. On the pop-up box, there are a number of tabs:  

o Alignment: specify the alignment of the text (left-aligned, center-aligned, right-aligned)  
o Font: specify the font, font style, and size  
o Number: specify how the data in the cell should be formatted (should it be displayed as a 

percentage, currency, regular text, etc.)  
o Patterns: specify the color of the cells  

4. Let's make our headings to be Helvetica font, Bold, and 12 pt size with center horizontal 
alignment.  (Use Font and Alignment tabs)  

5. Choose also Wrap Text option in the Alignment tab.    
6. We also specify specifically that it contains text data.  (Use Number tab)  
7. Select a color for the cells, ie. light yellow.  (Use Patterns tab)  
8. Click OK.  

Viewing the Formatting Toolbar  

1. Select View->Toolbars->Formatting 
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Applying Border  

1. Select our complete table now.  
2. Click on Format->Cells. 
3. Click on the Border tab in the dialog box.  
4. Choose one and see how it looks.  (We can undo a border by choosing None).  

Entering FormulasEntering FormulasEntering FormulasEntering Formulas    

Finding the minimum score:  

1. In cell C15, enter: Min Score  
2. In cell D15, we want to find the minimum scores of all the History scores listed.  We're going to 

use a pre-defined Excel function called Min. 
3. *In Excel, we specify a formula always with an equal sign.  So, in cell D15, we enter: 

=Min(D7:D11)  
4. *We can also use regular arithmetic operators like +, -, *, / to specify formulas, but remember to 

always use the = sign in front. 
5. Notice how we specified a range of cells.  

With D7:D11, we are specifying the range of cells in Column D from rows 7 through rows 11.   
Similarly, if we wanted to specify the range of cells in Row 7 from Columns D through F, we 
would write D7:F7.  

6. And the function we used is called Min which returns the smallest number in a set of values.    
7. *Remember also that we need to enter a parenthesis after the function and we need to close the 

parenthesis at the end.  

Copying a formula to adjacent cells:Copying a formula to adjacent cells:Copying a formula to adjacent cells:Copying a formula to adjacent cells:    

1. Now we want to get the minimum of all the CS110 and Pre-Calc Scores.  
2. Instead of typing in our formulas, we can copy the formula we already entered.  Excel is smart 

enough to change the formula automatically to refer to the new column or row.  
3. Click on the cell containing the formula, which is cell D15  
4. Right-Click on the cell D15 and Choose Copy.  
5. Select the adjacent cells (E15 and F15).  
6. Right-click and choose Paste. 
7. Click on the cell E15.  See how in the formula bar on top, Excel automatically figured out the 

formula =Min(E7:E11).  Similarly, it did the same for F15.  

Finding the maximum score, average, sum:  

1. Since there is a min function, there is also a max function which returns the largest number in a set 
of values.  

2. So, let's enter in cell C16: Max Score.  Figure out what the formula should be. 
3. Enter the formula in D16 to find the max History score.  Then cut and paste the formula to the two 

adjacent cells.  
4. Then enter in cell C17: Average  
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5. Enter the formula in D17 to find the average History score.  Then cut and paste the formula to the 
two adjacent cells.  

6. Then enter in cell C18: Count  
7. Enter the formula in D18 to find a count of the number of History scores.  Then cut and paste the 

formula to the two adjacent cells. 

Some commonly 

used functions   

Function Name Meaning Format 
Average Returns the average of the arguments =Average(arg1,..) 
Sum Returns the sum of the arguments =Sum(arg1,...) 
Count Counts the number of cells that contain numbers =Count(arg1,...) 
Counta Counts the number of cells that are not empty =Counta(arg1,...) 
Countif Counts the number of cells within a range that meet 

a specific criteria 
=Countif(range, criteria) 

Max Returns the maximum of a list of values =Max(arg1,...) 
Min Returns the minimun of a list of values =Min(arg1,...) 
If Returns one value if the condition evaluates to True, 

another value if the condition evaluates to False. 
=If(condition, value_if_true, 
value_if_false) 

 
Finding the number of History scores that are higher than 85:  

1. In Cell C19, enter: Countif >85  
2. In Cell D19, enter: =Countif(D7:D11, ">85")  
3. Copy the formula in D19 to E19 and F19 to calculate the number of CS110 scores higher than 85 

and the number of Pre-Calc scores higher than 85 respectively.  

Finding the Total Score (a sum of the history, cs110, and Pre-Calc scores for each 

person)  

1. In cell G7, enter the formula to sum up the history, cs110, and pre-calc scores.  
2. We can either use the sum function or just use regular arithmetic operators like +. i.e. =d7+e7+f7 

or  =sum(d7:f7) 

3. *To edit a formula, go to the formula bar to edit, when done, hit return. 

Now let's say that all the students got an extra 15 points in extra credit and we want 

to add that into the Final Score Column.  

1. In cell H3, enter: 15  
2. In cell H7, enter: =Sum(G7,$H$3)  (Notice we use $ signs before the column and the row number 

here, why?)  
3. Copy this formula to the adjacent cells below for each person. 

Relative References vs. Absolute References:Relative References vs. Absolute References:Relative References vs. Absolute References:Relative References vs. Absolute References:    
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Relative references:   When you create a formula, references to cells or ranges are usually based upon their 
position relative to the cell that contains the formula.  This is known as a relative reference. When you copy 
a formula that uses relative references, Excel automatically adjusts the references in the pasted formula to 
refer to different cells relative to the position of the formula.  
 
Absolute references:   If you don't want Excel to adjust references when you copy a formula to a different 
cell, use an absolute reference. You can create an absolute reference to cell C1 by placing a dollar sign ($) 
before the parts of the reference that do not change. To create an absolute reference to cell C1, for example, 
use $C$1.  
 
Assigning a Grade in the Grade column: 
Let's say that a person earns a grade of A if the Final Score is > 280, otherwise, he's just getting a passing 
grade. 

1. In cell I7, enter: =If(H7>280, "A", "pass")  
2. Copy this formula to the adjacent cells below to calculate the grade for each person. 

Sorting a list:  

1. We'd like to sort on the CS110 score column (first order key) in ascending order, then sort by the 
Student Names (second order key) in Descending order.  

2. Select the entire table including the Header row (from row 6 to row 11).  
3. Click on Data->Sort  
4. Select Sort by CS110 and Click on Ascending.   On the next Then By box, select Student Name 

and click on Descending order.  
5. Notice how the data is sorted and the scores for each student are carried through the sorting.  
6. Notice also how the secondary order key (Student Name) broke the tie of CS110 scores between 

Tom and Sam. 

Making Charts:Making Charts:Making Charts:Making Charts:    

Make a Bar Chart of the CS110 and Pre-Calc Scores:  

1. Select the data.  First select the Student Name Column (Column C, rows 6 through 11).  Then 
holding the Apple key, select Columns E and F (rows 6 through 11).  

2. Click on Insert->Chart  
3. The first window asks us what type of chart we want.  Choose Bar, then click Next.   
4. Next it asks how the data series are arranged, in rows or columns.  Columns is automatically 

selected (which is what we want).  Data Range is the selected cells we've chosen and is the data 
that we want to plot, notice that there's a moving border on the data range.  

5. Click Next.  
6. Step 3 of Chart Wizard asks basically a bunch of options you can set up such as Titles.  
7. On the titles tab, enter for the Chart Title, CS110 and PreCalc Scores of Students  
8. Enter for the Category (X) axis: Student Name   
9. Enter for the Category (Y) axis: Score  
10. On the Gridlines tab, notice that the major gridlines checkbox is checked for the y-axis.  Uncheck 

it to see what it is.  Check the box again.  
11. On the Legend tab, you can choose where the legend appears, if at all.  
12. On the Data Labels tab, you can choose to show the value of each column by clicking Show 

Value.  
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13. Click Next.  
14. Step 4 of the wizard asks you if you want to create the chart as an object on the current worksheet 

or to create it as a separate sheet.  
15. Click on the option As New Sheet, the default name of the sheet is next to it in the text box.    
16. Click Finish.  
17. Now we've got a new sheet in our Excel workbook with the chart on it.  

Make a Pie Chart of the StudenMake a Pie Chart of the StudenMake a Pie Chart of the StudenMake a Pie Chart of the Student History Scores:t History Scores:t History Scores:t History Scores:    

1. Select the cells in rows 6 to 11 in columns C and D.   
2. Select Insert->Chart.  
3. Select Pie in the chart type.  
4. Click Next.  
5. Select Columns for Series In since our data is arranged in again a Column.  
6. On the Data Label tab, select Show Value or Show Percent.    
7. On the Titles tab, put History Scores for Chart Title.  
8. On the Legend tab, you can select where the legend to be placed if you want.  
9. Click Next.  
10. Select As New Sheet when it asks us where to place Chart.    
11. Click Finish.  
12. Now we've got a new sheet with our Pie Chart on it.  

Showing Formulas:Showing Formulas:Showing Formulas:Showing Formulas:    

1. Go to Excel->Preferences  
2. In the Window Options pane, check Formulas.  
3. Click OK. 

Specifying a Print Area:Specifying a Print Area:Specifying a Print Area:Specifying a Print Area:    

1. Select the cells you want to be printed out.  
2. Click File->Print Area->Set Print Area  
3. Click on Print Preview  
4. Notice how only the cells you selected are in the Print Preview window.  

To clear out the Print Area:To clear out the Print Area:To clear out the Print Area:To clear out the Print Area:    

1. Click File->Print Area->Clear Print Area 

Printing with Gridlines, Column headings and Row numbers:Printing with Gridlines, Column headings and Row numbers:Printing with Gridlines, Column headings and Row numbers:Printing with Gridlines, Column headings and Row numbers:    

1. Click on Page Setup  
2. Click on Sheet Tab  
3. Check on Gridlines and Column Headings and Row numbers  
4. Click OK  
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5. Click on Print Preview.  

Printing in Landscape/Portrait Mode:Printing in Landscape/Portrait Mode:Printing in Landscape/Portrait Mode:Printing in Landscape/Portrait Mode:    

1. Click on Page Setup  
2. Click on Page tab  
3. Select either Landscape or Portrait mode.  
4. Click OK. 

Inserting a Footer:  

1. Click on View->Header and Footer  
2. Click on Custom Footer  
3. Enter your name in the left section.  
4. Enter your section number in the center section.  
5. Click on right section, then click on the Page number button.  
6. Click OK.  
7. Click OK.  

Inserting Worksheet:  

1. Go to Insert->Worksheet  
2. To move the order of the worksheets, just drag the sheet tab on the bottom to the place you want it 

to go to.  

Deleting Worksheet 

1. Click on the worksheet tab of the worksheet you want deleted.  
2. Go to Edit->Delete Sheet  

Rename Worksheet 

1. Just double-click on the worksheet tab and then type over the new name. 

 

 
 
 
 
 

    

 
 



 7 

 
 


